Partial Service Disruption - Claude access issue

Incident Report for ITS System

Resolved

The access issue has been resolved. We thank you for your patience.
Posted Apr 29, 2026 - 13:34 EDT

Investigating

Anthropic is reporting that Claude.ai and other services may be inaccessible especially when attempting to log in. They are working to resolve the issue.
Posted Apr 28, 2026 - 14:56 EDT
This incident affected: AI Tools & Applications (Claude for Education).