Campus network connectivity issues

Incident Report for ITS System

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 16:14 EDT

Monitoring

We have identified the source of the issues and have implemented a mitigation, currently monitoring.
Posted Mar 09, 2026 - 10:06 EDT

Investigating

We are currently receiving reports of campus connectivity issues and are investigating.
Posted Mar 09, 2026 - 09:33 EDT
This incident affected: Information Security (Firewall Services).