ITS Private Cloud OUTAGE - UTORrecover

Incident Report for ITS System

Resolved

✅ Resolved

UTORrecover has been fully restored following the power outage affecting our Toronto backup site. The service is now operating normally.

Backup jobs that were interrupted during the outage are currently running and may take longer than usual to complete as they catch up. No action is required on your part.

Thank you for your patience during this incident.
Posted Feb 17, 2026 - 14:29 EST

Monitoring

✅ UTORrecover is back online.

Backup jobs are resuming and many have already restarted. We are actively monitoring the service and will provide further updates as the situation progresses.

Any support cases that were opened during the outage will be addressed on a priority basis once the service has fully stabilized.
Posted Feb 17, 2026 - 10:31 EST

Investigating

Due to a major power outage in Toronto, our backup site has been affected, resulting in an unplanned service disruption. UTORrecover is currently unavailable, and all backup and restore jobs are suspended until further notice.

Our team is actively working to restore the service. Updates will be posted here as the situation develops.

We apologize for the inconvenience and appreciate your patience.
Posted Feb 17, 2026 - 09:17 EST
This incident affected: ITS Private Cloud Infrastructure (UTORbackup/UTORrecover).