CIS Service Disruption

Incident Report for ITS System

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 10:14 EDT

Investigating

The Course Information System (CIS) is currently unavailable. Our team is actively investigating the issue and working to restore service as quickly as possible. We will provide updates as more information becomes available. Thank you for your patience.
Posted Apr 13, 2026 - 09:51 EDT
This incident affected: Student Web Services (Course Information System).