Unplanned Outage - ACORN

Incident Report for ITS System

Resolved

The Acorn issue has been resolved and services restored.
We apologize for the inconvenience caused.
Posted Mar 24, 2026 - 09:16 EDT

Investigating

An unplanned outage is affecting ACORN. Users may be unable to access the service at this time. Our technical team is actively investigating and working to restore access as quickly as possible. We will provide updates as the situation evolves.
Posted Mar 24, 2026 - 08:26 EDT
This incident affected: Student Web Services (ACORN).