Unplanned Outage - REDCap

Incident Report for ITS System

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 13:16 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2026 - 13:08 EST

Investigating

An unplanned outage is affecting REDCap. Users may be unable to access the service at this time. Our technical team is actively investigating and working to restore access as quickly as possible. We will provide updates as the situation evolves.
Posted Mar 02, 2026 - 12:57 EST
This incident affected: Research & Library Systems (REDCap).