Intermittent issues affecting University of Toronto Homepage website

Incident Report for ITS System

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 01:49 EST

Identified

The University of Toronto Homepage website (https://www.utoronto.ca) is currently experiencing intermittent issues that may impact page response times. Service providers are actively working to resolve the issue.
Posted Jan 10, 2026 - 00:18 EST
This incident affected: Web Services (UofT Home Page).