MIM degraded performance

Incident Report for ITS System

Update

Technical staff continue to investigate the slowness affecting identity data synchronization. Sync updates are occurring, but at a reduced speed. This is a performance impact only, changes are still being processed successfully.
Posted Oct 31, 2025 - 08:24 EDT

Investigating

We are currently experiencing delays in Microsoft Identity Manager (MIM) synchronization processes, which may result in degraded performance across identity provisioning and updates. Technical staff are investigating the issue.
Posted Oct 20, 2025 - 11:27 EDT
This incident affects: Identity Management Systems (MIM).