M365 Exchange Online: Calendar and sent Items intermittently missing/not updating

Incident Report for ITS System

Update

We are actively working with Microsoft Premier Support to identify the cause and restore normal service.

In the meantime, please advise users that calendar updates may be delayed; however, the meeting should still appear within 1-3 hours.
Posted Jan 22, 2026 - 14:26 EST

Identified

The M365 team is investigating reports of Exchange Online issues affecting calendar functionality (missing or unsynced delegate/resource calendars, invites not appearing after acceptance, and shared mailbox calendar events disappearing).
Some users may also see sent messages not appearing in Sent Items.
We are actively working with Microsoft Premier Support to identify the cause and restore normal service.

Workaround: Until this is resolved, delegates may manually enter meeting details into their executive’s calendar.
Posted Jan 22, 2026 - 11:22 EST

Investigating

Microsoft is investigating an issue where some users may be unable to access Microsoft 365 services, including Teams and Outlook. Microsoft is actively working to resolve the issue.

Observed symptoms may include, but are not limited to:
- Delegates accept calendar invitations on behalf of an executive, but the meeting does not appear in the executive’s calendar.
- Delegate views of executive calendars are not syncing or updating as expected.
- Calendar events created from shared mailboxes briefly appear after clicking Send, then disappear and do not appear in Sent Items (Outlook desktop and Outlook on the web).
Posted Jan 21, 2026 - 13:00 EST
This incident affects: Email Systems (Office 365, UTMail+).