GeneralVPN connectivity issues

Incident Report for ITS System

Monitoring

Users running older operating systems may experience certificate errors when connecting to UTORvpn (GeneralVPN). Please ensure your OS is updated to ensure the latest CA certificates are on your system. In particular, Linux users may benefit from running 'update-ca-certificates' or equivalent.
Posted Apr 13, 2026 - 16:33 EDT

Investigating

We are currently investigating an issue with users connecting to GeneralVPN
Posted Apr 13, 2026 - 13:38 EDT
This incident affects: VPN Services (UTORvpn (Cisco Secure Client)).