Unplanned Outage - UTOMR Application

Incident Report for ITS System

Resolved

The issue affecting the UTOMR service has now been resolved. Thank you for your patience while we addressed the problem.
Posted Apr 09, 2026 - 16:00 EDT

Investigating

A partial unplanned outage is affecting the UTOMR service integrated with Quercus. Users may be unable to access the service at this time. Please note that access to Quercus itself is unaffected. Our technical team is actively investigating and working to restore access as quickly as possible. We will provide updates as the situation evolves.
Posted Apr 09, 2026 - 15:02 EDT
This incident affected: Academic ToolBox (Other).